Loading URL causes flashing and Application not found

Aug 19, 2009 at 6:09 AM

I am really finding Kooboo fascinating and want to install it. I performed the procedures located at http://www.kooboo.com/docdetail/Kooboo_installation_guide. When loading up http://localhost/form it tries to load the application but the browser is flashing and I see the status bar blinking Application Not Found. If I go to http://localhost/default.aspx (I know you must go to the previous url first) ti says Server Error in '/' Application, The resource cannot be found. Are there hard coded dependencies? Installed the application in c:\kooboo\kooboocms\kooboo which is also my home directory in IIS. 

 

Any ideas on what is wrong?

 

Environment:

Windows Server 2003

IIS 6.0

MSSQL Server 2005

Kooboo Community Edition: 1.0.1.0

ASP.NET 2.0.50727.3053

(I do have ASP.NET 3.5 installed)

Coordinator
Aug 19, 2009 at 1:43 PM

Dear Sir,

It sems to me that you are using an older version of Kooboo. please download a latest version again from codeplex. The new updated release should have a better friendly message when "application not found".

Please do the following and report again if you still have problems.

1. Download a latest version again.

2. Make sure the site in IIS is runing under ASP.NET 2.0. Some machine will default map a site ASP.NET 1.1 when created.

3. Check * (wildcard) file extension in IIS is map to ASP.NET 2.0 ISAPI_Filter as described in the installation guide.

After above steps, if you still have any problem, please report back with the error message.

Thanks,

Guoqi @ Kooboo team

Aug 19, 2009 at 3:35 PM

Thanks for your reply.

I have downloaded the Kooboo Community edition zip file created today, made sure ASP.NET 2.0 (thats the only option), and checked the * file extension is maped to the ASP.NET 2.0 aspnet_isapi.dll file.

The error I am receiving is "The page isn't redirecting properly" in Firefox 3.5. This typically could be a cookies problem but I ensured cookies were enabled. The address in the address bar shows: http://localhost/Info/ApplicationNotFound?path=%2Fscripts%2Fisapi_srun.dll%2FInfo%2FApplicationNotFound.

Still hunting down the problem.

Aug 19, 2009 at 4:44 PM
Edited Aug 19, 2009 at 11:24 PM

As I can see.. I had installed Resin in IIS also. I guess isapi_srun.dll and aspnet_isapi.dll were conflicting with each other. Once i removed isapi_srun.dll and restarted, everything worked as described in the installation manual.

Thanks for your help! I will write a review after I test out the software.

Edit:

It was not isapi_srun.dll and aspnet_isapi.dll conflicting each other. It was that Kooboo does some nifty tricks with the URL. That is why the URL led to the application not being found. This is also most likely why you must have Kooboo installed in the root. Kooboo uses ASP.NET 3.5 URL Rewriting classes.

 

Coordinator
Aug 19, 2009 at 5:46 PM

Good that it worked out! we will make a note on this problem.

Regards,

Guoqi @ Kooboo team